证书应用环境用户手册

北京数字认证股份有限公司

北京市海淀区北四环西路68号双桥大厦15层

TEL：86-10-58045600 FAX：86-10-58045678

邮政编码：100080


前言

本手册适用于证书应用环境V2.12到2.14版本,内附截图涉及到的业务网址以产品发布时实际业务系统网址为准，此手册仅供参考。


一、主要功能

证书应用环境包括：安装程序、证书助手、客户端应用组件及在线升级工具四大功能模块，为您提供12大功能:

1. 安装运行环境；

2. 查看数字证书信息；

3. 修改数字证书密码；

4. 导出证书到本地文件；

5. 对一些常用应用网址的管理（添加、删除等操作）；

6. 对证书应用环境进行检测并修复检测出的问题；

7. 对介质及证书进行自动诊断并修复诊断出的问题；

8. 为用户提供证书业务办理及业务咨询的快速入口；

9 为用户提供客户端软件日志管理功能；

10. 自动升级客户端软件到最新版本；

11. 与应用系统集成完成证书登录、数字签名、验证签名等业务操作；

12. 证书到期提醒；


二、环境要求

1.硬件环境

1）CPU:主频1GHZ及以上

2）内存：至少512M

3）硬盘：至少100MB剩余空间

4）USB接口：至少一个USB2.0接口

2.软件环境

1）系统支持

Windows 10（32位和64位）

Windows 8.1（32位和64位）

Windows 8（32位和64位）

Windows 7（32位和64位）

Windows XP（SP2以上）

Windows Server 2003

Windows Vista

Windows server 2008 （32位和64位）

Windows 2000（SP4以上）

2）浏览器支持

IE浏览器：6.0及以上版本；

其它浏览器：Egde、Google Chrome、Firefox、Opera、Safari、360、遨游、搜狗。

3.权限要求

安装证书应用环境时当前用户必须具备管理员权限。


启动运行

双击“BjcaCertAide.exe”，助手会先检测您的基本应用环境是否正常，如果弹出图3-1所示的界面，请重新安装助手；

图3-1 助手损坏提示界面

这个过程可能会因为所使用机器性能的缘故有一定的时间消耗（1s-3s）,您也可以在助手正常启动后设置启动助手前是否需要检测基本应用环境；

如果您不具有管理员权限时，则会出现提权窗口：此时需要您输入管理员密码，点击确定，助手正常启动后会弹出图3-2所示的“首页”界面；

图3-2（1）助手正常启动界面

图3-2（2） 助手正常启动界面（一证通用户）

如果没有可用的证书（Usbkey设备证书和文件证书）则会弹出如图3-3所示的界面；

图3-3（1） 未插入key时的界面

图3-3（2） 未插入key时的界面（一证通用户）

对于一证通用户，所有界面风格以蓝色为背景；非一证通用户则以标准的红色为背景；

用户提权过程中，由于某些用户的非管理员权限自身就受到提权限制，提权权限不足，此时出现提权不成功现象，只能以非管理员权限运行。如果仍需要管理员权限运行，请联系系统管理员，切换到管理员权限登录后，再运行证书助手。

如果放弃提权，证书助手以非管理员权限运行，此时证书助手具备基本的检测功能和证书信息查询等功能，其他功能(修复、升级等)将受到限制，不能使用。


UsbKey异常自动诊断

注：UsbKey异常自动诊断功能只针对V2.10.2及之后的版本；

当启动助手和插拔UsbKey时都会触发该功能，用户只需根据弹出的提示框来做相应的操作即可；

Ø 当插入一个或多个UsbKey设备时，如果该UsbKey可以正常使用，则显示正常页面；

Ø 如果未插入UsbKey设备，也没有文件证书，则会弹出如下图所示页面：

这是提醒用户没有插入UsbKey设备，并且系统中也没有文件证书；用户可以通过选中“不再提醒”来设置之后在使用助手时遇到这种情况不再弹出提示框，也可以在“设置”页面中选中“没有插入UsbKey时提醒”这一项再次设置提醒功能，或者不选中“没有插入UsbKey时提醒”这一项使使用助手时遇到这种情况不弹框提示；如下图所示：

Ø 如果未插入UsbKey设备，但是有文件证书，则显示如下图所示页面：

用户也可以通过选择“不再提醒”来设置在此种情况下之后使用助手时不再提示，也可以在设置页面中选中“没有插入UsbKey时提醒”这一项再次设置提醒功能，或者不选中“没有插入UsbKey时提醒”这一项使使用助手时遇到这种情况不弹框提示；

Ø 如果插入一个UsbKey无法正常使用，则会弹出如下图所示的提示页面：

用户可以点击“确定”按钮打开北京数字认证股份有限公司的自助服务平台，也可以点击“取消”按钮来关闭该提示窗口；

Ø 如果插入多个UsbKey设备，并且这几个UsbKey设备都没有证书，则会弹出如下图所示的提示页面：

Ø 如果插入多个UsbKey设备，但是有一部分UsbKey设备没有证书，则会弹出如下图所示的提示页面；

Ø 如果只有一个UsbKey设备存在时，如果该UsbKey的证书不是BJCA颁发的证书，则会弹出如下图所示的提示页面；

Ø 如果只有一个UsbKey设备存在，并且该机器上没有安装该UsbKey的驱动，则会弹出如下图所示的提示框：

用户可以点击“确定”按钮来安装驱动（需要能连接到网络），安装驱动需要一定的时间，请用户耐心等待；用户也可以点击“取消”按钮来关闭该提示框，放弃此次安装驱动，相应的该UsbKey就无法正常使用；

Ø 如果只有一个UsbKey设备存在，并且智能卡服务未开启（针对飞天3000和飞天3000gm类型的设备），则会弹出如下图所示的提示框：

用户可以点击“确定”或“取消”按钮来关闭窗口，为了UsbKey的正常使用，用户可以根据提示来重启业务系统，此处的业务系统指该UsbKey设备要使用的环境（比如，浏览器，证书助手等），也可以重启电脑；


证书到期提醒

注：证书到期提醒功能只针对V2.12及之后的版本；

当插入UsbKey时会检测当前证书的有效期，如果有过期证书则在桌面右下角弹出提示窗口，提示内容如下：

1、提示当前有效期；如果证书的有效期截止日期小于即将到期天数（默认60天），提示用户证书即将到期；如果已经过期，提示用户已经过期；

2、除了有效期提示外，还提供证书即将到期时的更新链接，证书如果即将到期，可通过更新链接，进入到更新页面；

3、提供证书助手的帮助平台页面链接，如有其他需要了解的问题，可通过“自助服务平台”链接进入到用户自助服务平台。

当仅插入一个UsbKey时，会判断当前用户证书是否过期，如果证书已经过期则会提醒用户证书过期，需要更新，如下图所示：

当插入多个Usbkey时，会对所有用户的证书做判断，判断是否包含过期证书，如果包含一个过期证书则会提醒用户证书过期，需要更新，如下图所示：


首页

首页展示“证书信息”、“常用应用”、“综合服务”“修改密码”、“找回密码”、 “证书更新”等基本功能以及设置、帮助和关于页面的快捷键。


证书信息

提供对您的数字证书基本信息的查看功能，如果插入多个Key则会显示当前所选择Key的信息，您可自己选择要查看的证书，如图3-4所示；

图3-4 证书信息

如若要查看更详细的信息，请点击“更多信息”；

如果当前所选择的是Key证书则弹出如图3-5所示的界面；

图3-5 更多信息（Key证书）

如果当前所选择的是软证书则弹出如图3-6所示的界面；

图3-6 更多信息（软证书）


检查证书

在证书管理界面点击“检查证书”按钮，开始检查所选择的证书有效性的密钥，默认检测密钥只检测公钥，私钥检测是可选项，如果需要检测私钥，需要在弹出的私钥检查确认窗口中点击按钮“是”然后输入密码，检查私钥窗口如下图3-7所示，如果不需要检查私钥时，在弹出的确认窗口中点击按钮“否”即可，检查私钥时只会在该证书第一次检查时需要输入密码。

图 3-7 私钥检查

检查私钥结果如下图3-8所示。

图 3-8 私钥检查结果


导出证书

在证书管理界面点击“导出证书”按钮，弹出证书导出窗口，如图3-9所示，选择要导出证书的位置，输入导出的证书名称后，点击保存，即可导出用户证书。

图 3-9 导出证书


备份软证书

选择软证书后，会出现软证书操作按钮，在证书管理界面点击“备份软证书”按钮，弹出证书密码输入窗口，如图3-10所示；正确输入密码后，开始备份软证书，备份完成后弹出完成窗口，提示备份的文件名，并提示及时保存备份文件，如图3-11所示；确认提示后，自动打开备份的软证书路径，如图3-12所示，可以将软证书文件复制到其他位置进行保存。

图 3-10输入口令

图 3-11 备份成功后提示

图 3-12 打开备份路径


删除软证书

选择软证书后，会出现软证书操作按钮，在证书管理界面点击“删除软证书”按钮，弹出证书密码输入窗口，正确输入密码后，软证书成功删除。


修改密码

在首页点击“修改密码”按钮，弹出密码提示窗口，提示用户确认修改密码的证书，确认证书后，弹出修改密码窗口，输入当前密码、新设密码、确认密码，点击“确定”按钮后，修改当前证书密码。

图 3-13 修改用户密码

修改密码时须按照新密码格式输入新密码：

Ø 新密码必须使用6-16个字符，并区分大小写；

Ø 新密码必须是数字和字母的组合；

Ø 两次输入的新密码必须一致；

Ø 新密码不能输入相同字符；

图 3-14 新密码校验未通过


找回密码

打开IE浏览器，并跳转到找回密码对应的地址；


证书更新

打开IE浏览器，并跳转到证书更新对应的地址；


环境检测

本功能会详细的检测您的机器环境是否满足证书应用环境运行使用的要求，并将详细的检测项结果显示给您。

检测项分为以下条目：

操作系统检查：检查操作系统版本是否支持证书应用环境

Ø 版本检查（操作系统）。

浏览器检查：检查IE浏览器的设置以及其他浏览器支持项的设置是否满足证书应用环境设置的要求

Ø IE版本检查（IE浏览器）。

Ø IE安全级别检查。

Ø IE隐私设置级别检查。

Ø IE保护模式检查。

Ø IE兼容性视图检查。

Ø IE可信站点安全级别检查。

Ø 其他浏览器支持项检查。

控件检查：检查证书应用环境的控件是否正常安装(X86系统只检测32位控件)

Ø XTXAppCom.dll

Ø XTXAppCom_X64.dll

软证书环境检查：检查软证书环境是否正常

硬件检查：检查USB-Key证书设备是否接入，以及是否为有效证书

驱动检查：检查当前USB-Key的驱动是否已经安装

证书助手启动后，点击 “环境检测”即可，检测界面如图3-15所示。

图 3-15 正在检测

当检测项全部通过时，显示如图3-16所示的界面；

图3-16 检测通过

您此时可点击“重新检测”再检测一遍，亦可点击“首页”返回首页；

当有检测项不通过时显示类似如图3-17的界面；

图3-17 检测未通过

此时，您需要点击“全部修复”进行修复，亦可点击“详情”查看未通过项的具体信息；

全部修复可以修复检测过程中不满足证书应用环境的设置（包括浏览器设置、控件安装、驱动安装等）。

只能修复IE设置、控件等问题，对于用户的操作系统版本、IE版本、USB-Key未插入等不可修复项给出提示和建议。

非管理员权限运行的证书助手，不能进行修复操作。


检查更新

点击左下角“检查更新”，弹出如图3-18所示界面；

3-18 检查更新

点击弹出界面的“检查更新”按钮，检查当前是否有最新的证书助手更新版本，如果有最新版本，显示最新版本的信息。


设置

点击“设置”进入如图4-1 所示页面

图4-1 设置页面

主要包括四大项设置：系统环境、自动更新、日志管理、消息提醒；


系统环境

点击右上角的“恢复软证书”，弹出选择证书备份文件窗口，默认路径为本机备份软证书的路径，如图4-2所示；选择一个正确的证书备份文件后，输入证书密码，开始恢复软证书，软证书恢复完成后，就可以在首页中的证书信息列表中看到刚才恢复的软证书。

图4-2 恢复软文件证书

如图4-1所示，如果选中“启动前检测证书助手基本环境”，则助手在每次启动前先会检测证书基本应用环境是否正常，如果出现异常助手会自动修复，如若修复不了则给出提示；反之，则不检测，这种情况可能会使助手无法正常使用。由于所使用机器性能的问题，这个过程可能会消耗（1s-3s）的时间。

显示当前用户的操作系统版本以及IE浏览器的版本；


自动更新

如图4-3所示，可以自己选择或输入证书助手自动更新的时间，可以选择7天，15天，30天，或者自定义，自己确定多少天更新。

图4-3 自动更新设置


日志管理

如图4-4所示，可以设置生成日志的级别以及大小；可以清空日志也可以导出日志到指定目录（如图4-5）；

图4-4 日志管理

4-5导出日志


消息提醒

如图4-6所示，可以自己设置消息提醒的时间和消息展示时间；

图4-6消息提醒设置


关于

点击“关于”标签，打开关于页面，显示客户端常用的组件版本及安装信息，如图5-1所示。

图5-1关于


常用网址

点击“常用网址”出现如图6-1所示的界面；

图6-1 常用网址

此处显示的是一些常用的网址的链接，您可点击某一项打开其链接，亦可点击“管理”，弹出如图6-2所示界面；

图6-2 管理

您可以在此处添加你经常使用的应用，必须输入应用名称和应用地址，然后点击添加即可；

点击 hideedit 按钮可以隐藏如图6-2所示的添加功能；

点击 showedit 按钮可以显示如图6-2所示的添加功能；

选中您需要操作的应用名称，可以对其进行打开、删除、上移和下移操作。


助手指南

点击左侧“助手指南”标签，打开用户操作手册，查看帮助文档。


打开证书助手

左键点击桌面上的托盘图标 [image] 打开证书助手；或者右键点击托盘图标 [image] ，然后在快捷菜单中点击“打开助手”菜单项也可以打开证书助手。


退出证书助手

右键点击托盘图标 [image] ，然后在快捷菜单中点击“退出”菜单项可以退出证书助手。


四、在线升级

在您首次运行证书应用环境的安装程序之后，系统便为您安装了“在线升级工具”，它会在您的系统上以静默方式自动运行，若发现新的软件版本，则会下载到您的机器上，并自动启动运行，弹出欢迎”界面，由您决定是否安装最新版本的软件。

如果您点击“安装”，则安装程序会继续运行，直到完成新版本证书应用环境的安装，具体过程可参照本文第三章的“安装”说明内容；

如果您点击“取消”，则安装程序退出，您可继续使用之前已安装的较低版本“证书应用环境”，您还可以在下一次“在线升级工具”提示您进行更新安装时完成新版本证书应用环境的安装。


五、服务与保障

BJCA 为所有证书用户提供全套的软件工具包，帮助用户高效的使用BJCA所颁发的数字证书。

一旦您在任何BJCA注册机构或受理点办理了数字证书，您就成为我们的证书用户，在证书有效期内您将获得如下服务：

证书管理软件更新。

证书管理软件的安装、配置及使用支持，用户可以通过电话或者电子邮件获得此服务。

获取BJCA产品更新信息，获取世界上新近流行的网络安全信息。

BJCA并不提供有关操作系统的使用及性能方面的服务支持和其他技术支持。


证书助手问题

针对于用户在使用BJCA证书助手过程的遇到的问题，本节提供了常见问题的详细解答。

1. 问题: 为什么在打开证书助手—》证书信息时，会提示“没检测到证书，请检查您是否插入USB-Key”

有如下几种可能:

·首先请您确认是否有BJCA发放的USB-Key插入电脑,如有插入，或USB接口已损坏,请检测USB接口，确认USB-Key能够正常连接电脑。

·USB-Key驱动程序被误删除，请重新安装证书应用环境。

·USB-Key内证书损坏，请拨打我们的热线电话寻求技术支持。

热线电话：(010)58515511

·USB-Key硬件损坏，请到原证书办理点进行更换，更换原则请参照《质保说明》。

2. 问题：插入USB-Key时，提示我证书已过期，该怎么办？

证书助手会自动检测到您的证书即将到期，并提示您进行证书更新，如果您希望继续使用数字证书，有如下两种方式可助您完成证书更新：

1）自动更新：当您在使用证书的过程中，证书应用环境会在您的证书到期之前自动帮您完成证书更新，整个过程无需您的参与。

2）受理点更新：请您在证书到期前的到您的证书办理点办理证书更新业务，请您在办理更新业务时携带好您的USB-Key，这样您将不需要支付证书介质费用。

3. 问题：为什么我的安全站点无法访问？

请选择“Internet 选项”—》“安全”—》“本地Intranet”，将“该区域的安全级别”改为“中-高”，如“图6-1 修改安全级别”所示。

图6-1 修改安全级别

4. 问题：我的机器安装了杀毒软件（以360安全卫士为例），当我在安装“证书应用环境”的过程中，弹出了“ 图6-2 防火墙提醒”所示的界面，我该怎么办？

图6-2 防火墙提醒

为了保证证书应用环境的正确安装，请您选择“允许程序的所有操作”。

5.问题：我刚刚更新了证书，为什么显示的依然是旧的证书信息？

界面上显示的旧的证书信息是系统升级之前的证书信息，该信息来自系统缓存，在每次USB-Key插拔时刷新对应的证书信息内容，由于更新用户证书是直接下发到USB-Key中，需要重新插拔一次USB-Key，才会将新证书信心读到系统缓存中。

6. 问题：我用谷歌浏览器(chrome)打开业务网站后，为什么没有显示证书信息？

因为chrome浏览器阻止了证书业务的控件，或者chrome浏览器本身不支持业务系统的网站，可尝试对chrome浏览器做如下方式更改，在地址栏输入“chrome://plugins/”，然后在页面的 ActiveX hosting plugin for Firefox/Chrome - signature-选项后勾选“”始终允许，如图6-3所示，然后重新打开业务网站，如果还是无法显示证书信息，可能是由于业务网站本身不支持谷歌浏览器使用证书登录业务系统，建议用IE浏览器打开业务网站。

图6-3 chrome浏览器设置

7. 问题：我用其他浏览器(例如:火狐)打开业务网站后，为什么没有显示证书信息？

可能是由于业务网站本身不支持其他浏览器(例如:火狐)使用证书登录业务系统，建议使用IE浏览器打开业务网站。


关于我们

北京数字认证股份有限公司(原北京数字证书认证中心，简称“BJCA”)成立于2001年2月，是北京市国有资产经营有限责任公司控股的国有企业，是国内领先的信息安全解决方案提供商，主要业务为电子认证服务、电子认证产品及可管理的信息安全服务。

BJCA是高新技术企业和软件企业，是具有工业和信息化部颁发的电子认证服务许可证资质，国家密码管理局颁发的商用密码销售、使用许可资质和电子政务电子认证服务许可资质、卫生系统电子认证服务资质的电子认证服务商;是具有国家风险评估资质、国家应急处理资质、国家信息安全服务安全工程类资质和北京市信息安全服务资质的信息安全服务提供商。

作为领先的电子认证企业，BJCA遵照《中华人民共和国电子签名法》的要求和相关管理规定，同时为用户提供涵盖电子认证服务和电子认证产品的整体解决方案，建立起覆盖全国的电子认证服务网络和较完善的电子认证产品体系。应用领域覆盖政府、金融、医疗卫生、彩票、电信等市场，在电子政务领域的市场占有率位居行业前列，并已在医疗信息化、网上保险、互联网彩票等重点新兴应用领域建立了市场领先优势。

作为专业的可管理信息安全服务提供商，BJCA拥有国内一流的信息安全专家和服务团队，深刻理解各种信息安全政策、标准、指南和规范，遵循“分域防护、深层防御、分级保护、动态防范”的原则，建立起服务专业、响应及时、保障可靠的可管理的信息安全服务体系，为广大客户提供涵盖信息系统全生命周期的安全集成、安全咨询、安全运维等服务，多次为国属、市属重大工程保驾护航，特别是在2008年北京奥运信息安全保障工作中发挥重要作用，被北京奥组委授予奥运政务网络和信息安全优秀服务企业。

经过十多年的高速发展，通过营造良好的企业文化，建立有效的激励机制，提供广阔的发展空间，BJCA已经成为人才荟萃、朝气蓬勃的创新型高科技企业，建立了一支拥有700多名员工，集产品设计、技术研发、工程实施、市场营销、经营管理和运行服务于一体的专业队伍，并将继续贯彻“以人为本，追求卓越，求实创新，和谐共生”的核心价值观，实现客户满意、员工进步、企业发展，不断向社会提供高品质的信息安全服务，帮助用户创建安全可信的网络空间。


联系我们

如果您有任何问题、意见或者建议，请提交给我们的注册机构，或者直接提交给北京数字认证股份有限公司。我们很乐意通过电话或者电子邮件为您提供和我们产品相关的服务。您所有的建议和意见都将得到我们认真的考虑。

地址：北京市海淀区北四环西路68号双桥大厦15层（左岸工社）100080

客服热线：(010)58515511

电话：(010)58045600

传真：(010)58045678

网址： http://www.bjca.org.cn

销售联系： market@bjca.org.cn

客户服务： service@bjca.org.cn

人力资源： hr@bjca.org.cn

法律事务： cps@bjca.org.cn